ATTENTION USERS OF WINDOWS XP AND VISTA…….

In order to comply with PCI DSS v3.1, BPS will not be able to support TLS v1.0 after June 3rd 2015. 

What does this mean?  On June 4th, if you are using Windows XP, Vista or any other Operating System or browser that only supports TLS v1.0, you will no longer be able to utilize BPS’s online E-Statement website.

 
   
   
BPS Telephone Company
120 Stewart St. • Bernie, MO 63822
573-293-2BPS (2277) • 800-785-8630 • Fax: 573-293-2299 | Regulatory Issues | Privacy | Terms & Contditions